libzip 版本过低或提示reinstall解决方法

问题说明:

在安装PHP7.3.2时,系统丢出了一个错误,编译zlib时提示 :

configure: error: Please reinstall the libzip distributio

configure: error:system libzip must be upgraded to version >= 0.11

安装libzip

既然说你的版本低了,那首先肯定得卸载现在的低版本:

yum remove libzip libzip-devel

然后:

wget https://nih.at/libzip/libzip-1.2.0.tar.gz
tar -zxvf libzip-1.2.0.tar.gz
cd libzip-1.2.0/
./configure
make && make install

不出意外的话,再次在PHP目录下执行 ./configure --prefix=... 就不会丢出上面的错误了。

技苑
请先登录后发表评论
  • 最新评论
  • 总共0条评论
  • © 2016-2020 技苑 版权所有 ICP证:鄂ICP备15021999号
  • 联系邮箱:master@pengxb.com